搬瓦工shadowsocks多端口密码手动配置方法

本文主要讲解shadowsocks(以下简称ss)设置多端口多密码方式,以搬瓦工VPS为例,当前系统环境为Centos6。

用过搬瓦工VPS的都知道,搬瓦工的VPS有一键设置ss功能,设置起来简单方便,这个一键设置的过程我就不说了,网上教程太多了,而且也太简单了。但是,如果通过一键的设置,你只能得到一个端口和密码,虽然说这个可以共享给别人,毕竟不方便,我在网上也搜集了好几个方法手动来配置ss多端口多密码的,但是你想通过这些文章配置成功也得花费一番功夫,还得综合几篇文章来看,有的人直接复制粘贴,有的就写的一半,有的配置不全,还有的标点符号大小写错误,所以导致你复制其他人文章里的操作代码的时候,总会出现报错的问题,综合了一下其他人写的文章,修改下错误,我整理下,提供一个简单快速的手动搭建的方法。

方法如下:

首先连接到你的VPS,怎么连接就不用我说了吧,连接的时候注意下你自己的端口和密码即可,密码忘了就重新生成个。

以root用户运行以下命令,一行一行的粘贴进去即可:

1、wget --no-check-certificate http://www.leoruby.net/mycollections/shadowsocks/ss.sh.bz2

2、bzip2 -d ss.sh.bz2

XP系统总是提示“不再收到Google Chrome更新”的解决方法

xp系统下面的chrome的最终支持版本为:49.0.2623.75

xp是一款非常经典的windows系统,虽然它的功能非常强大,但是现在很多软件的更新版本都不支持该系统。比如,我们如果在xp电脑中安装了旧版谷歌浏览器的话,每次启动chrome都会遇到“不再收到Google Chrome更新”提示。每次都要手工关闭,真的很麻烦。

解决方法:

右击打开电脑系统中安装的旧版谷歌浏览器属性,在目标一栏中路径最后面添加 --disable-infobars,然后点击确定即可(注意前面有一个空格)。

这样,就不会再有烦人的提示了。

解决Discuz升级的时候提示“请先升级 UCenter 到 1.6.0 以上版本”的问题

今天,正常升级discuz程序的时候,提示

“请先升级 UCenter 到 1.6.0 以上版本。
如果使用为Discuz! X自带UCenter,请先下载 UCenter 1.6.0, 在 utilities 目录下找到对应的升级程序,复制或上传到 Discuz! X 的 uc_server 目录下,运行该程序进行升级”

我的Discuz下载的是最新的版本安装包,里面的ucenter怎么可能不是最新的版本呢?

其实,ucenter本来就是一个鸡肋,垃圾功能,取消掉是最好的了。

现在又提示这个问题,看来discuz论坛程序在被腾讯收购之后,越来越走下坡路了。看看现在discuz官方网站的可怜样吧....

废话不多说了,百度了一下,解决这个问题的办法如下:

方法有两种:

第一、http://你的域名/install/update.php?step=prepare 直接输入

chrome浏览器下adblock plus官方下载地址

因为国内无法访问google商店,所以,无法从google官方安装adblock plus这款屏蔽网站广告的插件。

在此,我们可以直接在adblock plus的官方网站下载,下载地址如下:

https://downloads.adblockplus.org/devbuilds/adblockpluschrome/

下载的插件为开发版本的,挺好使用的。下载后自己手动安装就可以了。

手动安装方法:依次点击 菜单 更多工具 扩展程序 ,然后开启 开发者模式,然后将下载的插件拖动到 扩展程序页面 就可以进行手动拖动安装了。

刚刚发现360浏览器自动将京东商城的网址更改为带推广连接的网址

好吧,我手动输入的明明是jd.com,结果360浏览器自己跳转了好几个网址,最后变成的网址如下:

https://www.jd.com/?cu=true&utm_source=p.egou.com&utm_medium=tuiguang&utm_campaign=t_36378_917624_c&utm_term=aaa854c4a71d4cd18e639b624a667e94&abt=3

360浏览器,你还要脸不?我是自己手动输入的,不是通过你的链接点击进入的,竟然自动给我变成推广链接了。

别的购物网站比如淘宝等等还没注意是否也有这种情况,以前输完网址就没仔细看地址栏,今天突然发现了这个,瞬间对360浏览器毫无好感。

最近迷上了TVB的老电视剧

感觉部部都是经典啊。

现在的电视剧都太垃圾了!!!!!!!!

试用了一下drupal8,发现不同语言包下面的一个文章显示的问题

安装了英文版的drupal8之后,我发布了2篇测试文章,然后我升级了一下语言包为简体中文的。升级之后又发布了两篇测试文章。

然后我再看首页,发现那最初在英文版本中发布的两篇测试的文章竟然不显示了。后台有数据,可是我就是不知道怎么让他们显示出来。

然后,我卸载了中文语言包,发现在英文版本中发布的文章显示了。而我在中文环境中发布的两篇测试文章又消失了,不能显示出来了。

从而我得出:drupal8在每种语言包中发布的文章,只能在对应的语言包版本中显示。在其他语言包中无法显示出来。

不知道是不是我哪里设置的不对。看来对drupal8真的好好的研究研究才行啊。

本想把我的这个博客升级到drupal8的,但测试都这么有问题,看来得慢慢测试研究透了才行啊。

建站选择虚拟主机还是选择VPS?你真的需要VPS吗?

前段时间,我自己买了一个搬瓦工的VPS。因为我最初是在练习linux,而且有很多的问题,在我本地电脑的虚拟机中无法实践。所以,我购买了个搬瓦工的这个便宜的VPS做个简单的练习。然后,也就没有然后了。现在这个VPS基本也就没有什么用处了。当然,这个VPS不贵,一年才100元左右。我明年打算还是一直续费下去的。因为便宜,速度也不错。所以,也想一直保留这个VPS。

但是,正如你们看到的,我的这个博客,并没有迁移到我购买的VPS上面。依然使用的是虚拟空间。目前我觉得,虚拟空间对于我建立网站来说,已经足够使用了。而且,我还不用担心空间的配置问题。所有的配置,都是空间商弄好的,我只需要简单的点点鼠标就可以了。虽然我可以在VPS上面自己搭建博客系统,但我觉得,依然麻烦。安全、配置等各种问题,都是需要自己考虑的。而我,这个博客而已,懒得自己搞那么多。我太懒惰了。

纵观国内,大多数人买VPS,有很大一部分是用来翻墙的。我没有做VPN系统,因为我觉得,没有必要。因为有免费的VPN软件可以使用。自己再搭建系统,也显得麻烦。我也不是需要长时间的翻墙。也就是收收gmail的邮件,偶尔查查google而已。免费VPN软件的时长,也足够我使用了。

用ServerAlias在APACHE里一个站点绑定多个域名

<VirtualHost *:80>
ServerAdmin [email protected] #管理服务器的邮箱 一般都不需要填写
DocumentRoot /www/docs/dummy-host2.example.com #网站的目录
ServerName dummy-host2.example.com #需要绑定的域名
ServerAlias www.example.com #绑定的其他多个域名
DirectoryIndex example.php #设置默认的访问的页面
ErrorLog logs/dummy-host2.example.com-error_log #错误日志目录
</VirtualHost>

页面

Subscribe to 浩海凌波 RSS